SSH client not connecting

0 votes
asked May 9, 2018 by normschaef (160 points)

I just purchased the full version of the terminal emulator. I was able to establish an SSH connection successfully with the trial version, but now I cannot connect to my device using the purchased product.
Before installing the full version, I removed the trial version and eliminated all references from the trial from my code.

The error I'm seeing when I try an ssh.connectasync command is:
Id = 2, Status = WaitingForActivation, Method = "{null}", Result = "{Not yet computed}"

This leads me to think I need an activation code, but the website indicates no key is necessary for the full version.

Thanks for your help.

2 Answers

0 votes
answered May 9, 2018 by Lukas Matyska (59,010 points)

Yes, for full version you don't need activation code. It seems that you are still using trial version.

If you are using NuGet version, please get your key at

Actually, you can use NuGet key for all builds. Please, give this a try.

License key can be set like this:

// Add this line to your application to set your license key 
// before working with Rebex classes.
Rebex.Licensing.Key = "==YOUR_KEY_HERE==";
0 votes
answered May 9, 2018 by normschaef (160 points)


I downloaded the link sent when I purchased the full version
and received: RebexTerminalEmulation-2018R1.1-Full-(a series of letters here).exe

I ran uninstall trial version and installed the above Full version, but I received the error.

So, I shouldn't need a key since I've purchased and installed the full version.

commented May 10, 2018 by Lukas Matyska (59,010 points)
I have examined the error you got once more and I realized that the error is not related to Full or Trial versions at all. The `WaitingForActivation` is state of the Task returned by `ssh.ConnectAsync()` call.

Can you please send sample project to, so we can reproduce the issue?
commented May 11, 2018 by normschaef (160 points)

I've send a project sample to you. The zip file includes: readme, RebexTE (the .dll I created) and RebexTE-Unit Test for run against the dll file.

Thanks for your help.
commented May 14, 2018 by Lukas Matyska (59,010 points)
Thank you for sample code.

It showed, that you are calling `ssh.ConnectAsync()`, but you never await it.

I have sent you more details and suggestion in reply to your email.
commented May 14, 2018 by normschaef (160 points)

Thanks for the answer. After some research I decided I didn't need to connect asynchronously. I changed my code to ssh.Connect() and things worked fine.
Thanks again.