Permission denied (publickey, gssapi-with-mic password)??

0 votes
asked Jan 28, 2011 by Lize (120 points)
edited Mar 25, 2011

I use the terminal on a Mac that a professor loaned me. I use it to ssh into a server in another school. I always type in the password and have never attempted to configure it to login without me typing it in or whatever. I don't know much about command line or mac so I'm not sure what went wrong but after attempting to scp a file from the remote computer to my local computer, it asked me for my password. After typing it in (I'm sure I did it correctly) 3 times, it gave me this error:

Permission denied (publickey, gssapi-with-mic password).

I closed the terminal window and attempted to log back into the server and now I can't login because I get this same error. I have some limited access to the computer so I can't configure the ssh_configure file. I saw some posts speak about changing a setting called GSSAPIAuthentication or something to no but I can't alter this file. Is there a way to fix this problem? I mean, I caused it to happened somehow with my limited access to files, is there a way to fix this?

1 Answer

0 votes
answered Jan 28, 2011 by Lukas Pokorny (120,490 points)
edited Jan 28, 2011

Hello,

This is a Q&A forum for Rebex components like Rebex SFTP or Rebex SSH Shell. We cannot support third-party products, unfortunately.

However, the "Permission denied" part of the error message here simply means your password was not accepted. The rest ("publickey, gssapi-with-mic, password") just lists authentication methods the SSH server supports. There is not enough information to be able to tell what is going on. I'm afraid you will have to ask the server administrator to look into the log in order to tell what is going on.

...