Cannot add assemblies in Visual Studio

0 votes
asked Sep 22, 2015 by sturgeon86 (120 points)

Hi, When I tried to add a reference to any of the rebez component I get this error

A reference to "Rebex ...." could not be added.

I did not have this issue with the trial (which I did uninstall and restarted the computer before installing the full version)

Any idea that might help me ?

I am under Visual Studio 2008 and doing a Compact Framework 3.5 project in C#

Thanks

commented Sep 24, 2015 by Tomas Knopp (58,890 points)
Have you solved the problem or are you unable to add references even after trying my suggestions?

1 Answer

0 votes
answered Sep 23, 2015 by Tomas Knopp (58,890 points)

Hello,

.NET Compact Framework 3.5 is supported by Rebex. The error you get seems to suggest that you are trying to reference some incompatible assembly (i.e. assemlby targetting a different platform.)

Could you please try one more time and make sure you reference assemblies from the "netcf-3.5" folder installed on your computer?
The path to the .NET CF 3.5 compatible Rebex libraries is:

 "%Rebex installation path%\Rebex Components\bin\netcf-3.5"

Please give it a try and let me know whether it works now.

BTW, we also offer samples targetting VS 2008 and .NET CF 3.5 that get installed along Rebex components. You can find them on your computer at:

"%Rebex installation path%\Rebex Components\samples\source\vs2008-netcf-3.5

So you can give them a try as well.

commented Sep 24, 2015 by sturgeon86 (120 points)
Hi, thanks for the reply. I have found my mistake. Dll I was trying to add were already there since I tried them with the demo. SO I deleted demo one and added the full version one and it works !

Thanks
commented Sep 24, 2015 by Tomas Knopp (58,890 points)
Good that it works now. Thanks for getting back!
...