Rebex FTP/SSL -- delay when authenticating?

0 votes
asked Feb 4, 2010 by GJUNKIE (120 points)
edited Mar 31, 2011

I am using a trial version of the FTP/SSL component for dot net. when authenticating to an FTP server, there is a 30-35 second delay. I am using the WinForms client for testing. I see this delay even if I change the certificate verifier to Rebex.Net.CertificateVerifier.AcceptAll.

If I disconnect and then immediately re-connect, there is no delay. What is the delay, and how do I prevent it?

Thanks

Chris

==================================== *** EDITED: this is the debug-level log for a connection to ftp.rebex.net:

18:53:33.603 Info Info: Connecting to ftp.rebex.net:21 using Ftp 3.0.3588.0 (trial version).

18:53:33.618 Info Info: Using proxy none.

18:53:34.806 Debug Info: Connection succeeded.

18:53:34.993 Info Response: 220 Gene6 FTP Server v3.10.0 (Build 2) ready...

18:53:35.040 Info Command: AUTH TLS

18:53:35.212 Info Response: 234 AUTH command ok; starting SSL connection.

18:53:35.228 Debug Info: Upgrading control connection to TLS/SSL.

18:53:35.337 Info TLS: State StateChange:Negotiating

18:53:35.353 Debug TLS: HandshakeMessage:ClientHello was sent.

18:53:35.556 Debug TLS: HandshakeMessage:ServerHello was received.

18:53:35.571 Debug TLS: HandshakeMessage:Certificate was received.

18:53:35.587 Debug TLS: HandshakeMessage:ServerHelloDone was received.

18:53:35.587 Debug TLS: Verifying server certificate ('L=PRAHA, S=-, C=CZ, CN=REBEX CA, E=support@rebex.cz, O=REBEX CR s.r.o., OU=-').

18:53:35.603 Debug TLS: Certificate verification result: Accept

18:53:35.603 Debug TLS: HandshakeMessage:ClientKeyExchange was sent.

18:54:14.447 Debug TLS: CipherSpec:ChangeCipherSpec was sent.

18:54:14.462 Debug TLS: HandshakeMessage:Finished was sent.

18:54:14.666 Debug TLS: CipherSpec:ChangeCipherSpec was received.

18:54:14.681 Debug TLS: HandshakeMessage:Finished was received.

18:54:14.697 Info TLS: State StateChange:Secured

18:54:14.712 Info TLS: Connection secured using cipher: TLS 1.0, RSA, 128bit AES in CBC mode, SHA1

18:54:14.728 Info TLS: Session ID: SnnPVCPhhpa2FW1awNZNFXrP/0+egNyWepQWdloDlTo

18:54:14.744 Debug Info: Control connection upgraded to TLS/SSL.

...

Applies to: Rebex FTP/SSL
commented Feb 4, 2010 by Lukas Pokorny (109,650 points)
Hello, please set the "Logging level" to "Debug" (in the WinForm FTP Client) to produce a more detailed log. It looks like the delay occurs during the TLS/SSL negotiation phase and the debug log would contain more information about it. You can edit your post to include the more detailed log. We migth be able to tell more then.
commented Feb 4, 2010 by Lukas Pokorny (109,650 points)
Does this delay also occur when connecting to a different FTP server such as ftp.rebex.net? (Use port 21, "Explicit TLS/SSL" and "anonymous"/"guest" credentials.)
commented Feb 5, 2010 by GJUNKIE (120 points)
I connected to ftp.rebex.net and experienced the same delay. I updated the log in my post.
commented Feb 5, 2010 by GJUNKIE (120 points)
Oh, same behavior as before when I disconnect and re-connect to ftp.rebex.net: there is no delay the second time

1 Answer

0 votes
answered Feb 5, 2010 by Lukas Pokorny (109,650 points)

I just sent you a link to a new build of Rebex FTP/SSL with enhanced logging via e-mail along with additional instructions. Please check it out. We are unable to reproduce this delay and no one else seems to suffer from it, so we need your cooperation in order to solve this.

...