0 votes
by (230 points)

Dear Sir,

I purchased Rebex FTP about three years ago for use with Visual Studio 2008 and Framework 3.5. It has been working very well. I now need to add SFTP to a project that currently uses just FTP.

I downloaded the Rebex File Transfer Trial Pack and am attempting to deploy the trial pack without luck.

The steps that I followed were:

  1. I removed the following old references from my Visual Studio 2008 VB Framework 3.5 application:

Rebex.Net.Ftp Rebex.Net.ProxySocket

  1. I then did a Build / Clean and saved the project.

  2. I reloaded the project and added references to the following three components:

Rebex FTP/SSL for .NET - Trial Version, Version 4.0.5085.0, Runtime v2.0.50727, C:\Program Files (x86)\Rebex Components 2013 R3\bin\net-2.0\Rebex.Ftp.dll

Rebex Networking for .NET - Trial Version, Version 3.0.5085.0, Runtime v2.0.50727, C:\Program Files (x86)\Rebex Components 2013 R3\bin\net-2.0\Rebex.Networking.dll

Rebex Common Classes for .NET - Trial Version, Version 3.0.5085.0, Runtime v2.0.50727, C:\Program Files (x86)\Rebex Components 2013 R3\bin\net-2.0\Rebex.Common.dll

  1. However, in my Visual Studio project's list of references, all three references have a path of "<the system="" cannot="" find="" the="" reference="" specified="">"

I have confirmed that the components are in the directory listed above. I have tried another Build/Clean and a Build/Rebuild but I still have the error.

I then removed these new references, added the two old references to my purchased FTP product, and the application recognizes those references OK.

I have done the above install procedure twice with the same effect.

Do you have any suggestions?

Thank you.


Applies to: Rebex FTP/SSL

3 Answers

0 votes
by (230 points)
Best answer

We Have a Solution!

Visual Studio 2008 Framework 3.5

  1. Click on Project | Properties
  2. Click [Reference Paths...] The reference path shown is: C:\Program Files (x86)\Rebex Components 2013 R3\bin\net-4.0\

However, I'm trying to load references that are found in ...\net-2.0\

So to fix it:

  1. Select the bad reference path (in this case, the "\net-4.0\" path
  2. Click the [Delete] button
  3. Click the [...] button and find the correct path (i.e. the "\net-2.0]" path).
  4. Click [Add Folder]

Visual Studio will now find the paths for the Rebex references.

Thank you Jan for your suggestion. It started me thinking "outside the box".


0 votes
by (18.0k points)

I have just one idea: How did you add the references in the "Add Reference" dialog - through the ".NET" tab or through the "Browse" tab? Using the "Browse" tab would be more straightforward here.

If it doesn't help, try to add the references to a new clean project and write us, whether it is working.

0 votes
by (230 points)

Good suggestion.

If I start a new project then I can add the three Rebex components. I can add them from the Solution Explorer browser tab, or from the Project | Properties | References form, or from Project | Add Reference.

However, I can not add them to my existing project. Any ideas why? I have removed all Rebex references from the existing project yet I still get the <the system="" cannot="" find="" the="" reference="" specified=""> message in the Reference Path column.