SFTP PutFile Failure

0 votes
asked Jul 18, 2012 by catherine (160 points)
edited Jul 18, 2012

Hi, I am getting following exception when I tried to use sftp putfile method, wondering if somebody knows what could be the reason? I am using key authentication to login the sftp server, the login part is sucessful.

Exception - Rebex.Net.SftpException: Failure; The requested operation failed.
   at gbMKS.PEQpz.eCVvJZ(1dRwomZ , Type )
   at gbMKS.PEQpz.BGrFh(String , Qu2Ci , Boolean )
   at Rebex.Net.Sftp.1xTmHi(Qu2Ci , udycp , String , Stream , Int64 , Int64 , 27NpLhZ )
   at Rebex.Net.Sftp.1xTmHi(Qu2Ci , udycp , String , String , Int64 , Int64 , Int64 , 27NpLhZ )
   at Rebex.Net.Sftp.PutFile(String localPath, String remotePath)
Applies to: Rebex SFTP
commented Jul 18, 2012 by Jan Sotola (17,670 points)
edited Jul 18, 2012

It seems as a general error message when trying to start the PutFile operation. The "The requested operation failed" message comes from the SFTP server.

Do other operations (e.g. GetList or GetFile) work on the same connection? What is your value of the remotePath parameter?

It would also probably help us if you'd created a communication log according the following instruction: http://www.rebex.net/kb/logging/default.aspx You can post the log to this forum or you can better send it to support@rebex.net.

1 Answer

0 votes
answered Jul 18, 2012 by catherine (160 points)
edited Jul 18, 2012

There was some issue about our sftp server. Problem solved. Sorry for the post.