Problems downloading file

0 votes
asked Jun 8, 2012 by deano (240 points)
edited Jun 11, 2012

Problems downloading file

Only part of the file is getting downloaded works when using a linux tool

DEBUG Sftp(1) Command: SSH_FXP_READ (15, 0x313630333531323133392D2D31303333303038303630, 114688, 28672)

Then nothing after that

4 Answers

0 votes
answered Jun 8, 2012 by Lukas Pokorny (114,070 points)
edited Jun 8, 2012

The log looks like it doesn't come from the latest version of Rebex SFTP. Would it be possible to download the current release (2012 R1 as of today) and give it a try? It contains some bugfixes that might be related to this.

0 votes
answered Jun 8, 2012 by deano (240 points)
edited Jun 8, 2012

Is the upgrade covered as part f my original purchase The original one that I bough was Rebex SFTP for .NET, version 2.0.4086.0

commented Jun 8, 2012 by Martin Vobr (12,940 points)
edited Jun 8, 2012

Hello, every purchase comes with a one year support contract which entitles you to download all new versions released within 12 months after the original purchase. 2012 R1 was published in March 2012. If you purchased your license in March 2011 or later you will be able to download 2012 R1. More info on support contract can be found at http://www.rebex.net/shop/supportContract.aspx

0 votes
answered Jun 8, 2012 by deano (240 points)
edited Jun 8, 2012

Updated to RebexSftp-2012R1-Full.exe

still the same error

last few entries in log file are

2012-06-08 13:53:19.491 INFO Sftp(1)[3] Response: SSH_FXP_HANDLE (10, 0x2D313333313135353833382D2D3531313335333235)
2012-06-08 13:53:19.491 VERBOSE Sftp(1)[3] SSH: Sending packet SSH_MSG_CHANNEL_DATA (55 bytes).
 0000 |5E-00-00-00-00-00-00-00 2E-00-00-00-2A-05-00-00| ^...........*...
 0010 |00-0B-00-00-00-15-2D-31 33-33-31-31-35-35-38-33| ......-133115583
 0020 |38-2D-2D-35-31-31-33-35 33-32-35-00-00-00-00-00| 8--51135325.....
 0030 |00-00-00-00-00-70-00                           | .....p.
2012-06-08 13:53:19.491 DEBUG Sftp(1)[3] Command: SSH_FXP_READ (11, 0x2D313333313135353833382D2D3531313335333235, 0, 28672)
2012-06-08 13:53:19.491 VERBOSE Sftp(1)[3] SSH: Sending packet SSH_MSG_CHANNEL_DATA (55 bytes).
 0000 |5E-00-00-00-00-00-00-00 2E-00-00-00-2A-05-00-00| ^...........*...
 0010 |00-0C-00-00-00-15-2D-31 33-33-31-31-35-35-38-33| ......-133115583
 0020 |38-2D-2D-35-31-31-33-35 33-32-35-00-00-00-00-00| 8--51135325.....
 0030 |00-70-00-00-00-70-00                           | .p...p.
2012-06-08 13:53:19.491 DEBUG Sftp(1)[3] Command: SSH_FXP_READ (12, 0x2D313333313135353833382D2D3531313335333235, 28672, 28672)
2012-06-08 13:53:19.491 VERBOSE Sftp(1)[3] SSH: Sending packet SSH_MSG_CHANNEL_DATA (55 bytes).
 0000 |5E-00-00-00-00-00-00-00 2E-00-00-00-2A-05-00-00| ^...........*...
 0010 |00-0D-00-00-00-15-2D-31 33-33-31-31-35-35-38-33| ......-133115583
 0020 |38-2D-2D-35-31-31-33-35 33-32-35-00-00-00-00-00| 8--51135325.....
 0030 |00-E0-00-00-00-70-00                           | .....p.
2012-06-08 13:53:19.491 DEBUG Sftp(1)[3] Command: SSH_FXP_READ (13, 0x2D313333313135353833382D2D3531313335333235, 57344, 28672)
2012-06-08 13:53:19.491 VERBOSE Sftp(1)[3] SSH: Sending packet SSH_MSG_CHANNEL_DATA (55 bytes).
 0000 |5E-00-00-00-00-00-00-00 2E-00-00-00-2A-05-00-00| ^...........*...
 0010 |00-0E-00-00-00-15-2D-31 33-33-31-31-35-35-38-33| ......-133115583
 0020 |38-2D-2D-35-31-31-33-35 33-32-35-00-00-00-00-00| 8--51135325.....
 0030 |01-50-00-00-00-70-00                           | .P...p.
2012-06-08 13:53:19.491 DEBUG Sftp(1)[3] Command: SSH_FXP_READ (14, 0x2D313333313135353833382D2D3531313335333235, 86016, 28672)
commented Jun 8, 2012 by Lukas Pokorny (114,070 points)
edited Jun 8, 2012

Please try setting your Sftp object's Settings.DisableTransferQueue property to false. Does it product a different behavior?

0 votes
answered Jun 8, 2012 by deano (240 points)
edited Jun 11, 2012

still didnt work

_SFTP.Settings.DisableTransferQueue = True 'added _SFTP.Settings.UseLargeBuffers = True ' added _SFTP.GetFile(ItemName, DestinationFile)

Log file last entry DEBUG Sftp(1)[12] Command: SSH_FXP_READ (14, 0x2D3731313230373233382D2D373830323639333434, 98304, 32768)

commented Jun 8, 2012 by Lukas Pokorny (114,070 points)
edited Jun 8, 2012

Would it be possible to try adding _SFTP.Settings.UseSmallPackets = True as well?

commented Jun 8, 2012 by deano (240 points)
edited Jun 8, 2012

setting this correctly worked _SFTP.Settings.DisableTransferQueue = True

didn't need _SFTP.Settings.UseSmallPackets in the end

Thnaks for the help :-)

commented Jun 11, 2012 by Lukas Pokorny (114,070 points)
edited Jun 11, 2012

Thanks for letting us know!

This option disables sending multiple read requests simultaneously - Rebex SFTP does that by default to enhance speed, but it looks like it doesn't work with your SFTP server. What SFTP server is it, by the way?

...