0 votes
by (120 points)

Hi.

We downloaded the Sftp version 6.9 and tried it in Microsoft Visual Studio 2019. When we build the application, it's giving me the below error message.

Assembly 'Rebex.Networking' with identity 'Rebex.Networking,
Version=6.0.8348.0, Culture=neutral, PublicKeyToken=1c4638788972655d'
uses 'System.Runtime, Version=7.0.0.0, Culture=neutral,
PublicKeyToken=b03f5f7f11d50a3a' which has a higher version than
referenced assembly 'System.Runtime' with identity 'System.Runtime,
Version=4.1.2.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'

How can I solve this?

Thank you

Applies to: Rebex SFTP

1 Answer

0 votes
by (134k points)

This looks like you are referencing Rebex binaries for .NET 7.0 from a project targeting an earlier version of .NET or .NET Framework.

Please check the references in your projects and make sure to reference Rebex assemblies matching your project’s platform: https://www.rebex.net/kb/framework-support/

For example, for .NET Framework 4.6-4.8.1, use Rebex assemblies installed by default to "c:\Program Files (x86)\Rebex Components R6.9\bin\net-4.6" folder.

by (120 points)
My project is using .Net Framework 4.7.2
by (134k points)
And which Rebex DLLs does it reference? Would it be possible to open the project file using Notepad and copy&pasting the relevant section with these references? From the error message, it looks like it's referencing DLLs in c:\Program Files (x86)\Rebex Components R6.9\bin\net-7.0" folder instead of "c:\Program Files (x86)\Rebex Components R6.9\bin\net-4.6".
...