SYST command failing because server admin disabled it

0 votes
asked Mar 23, 2011 by Bobby 2 (120 points)
edited Mar 12, 2012

I'm using the FTP library and one the servers that my client is using has the SYST command disabled for security purposes. When attempting to connect to the server, it errs out with:

'SYST': command not allowed (500)

Is it possible to bypass this? Is it absolutely necessary that this call be made? I assumed it is necessary as it detects the OS.

  • Bobby
Applies to: Rebex FTP/SSL

1 Answer

0 votes
answered Mar 24, 2011 by Lukas Pokorny (124,610 points)
edited Mar 12, 2012

SYST command is only used when connecting to some FTP servers as part of server brand detection. It is not currently possible to bypass this, and although it is not absolutely necessary for this call to be made, it was never reported to cause any issues because even if the FTP server rejects the command, our code should simply ignore that and continue without any problems. In short - it should not err out. If it does, something is wrong somewhere. Does your client's FTP server close the connection when it receives the SYST command or something like that?

Anyway, we can easily add an option to disable this altogether. This should solve the problem regardless its cause. I will send you a link to a current build with this option soon.

UPDATE

The fix was published as a part of Release 2012 R1. DoNotDetectFeatures option now turns off server feature detection completely, not only the one using the FEAT command.

commented Mar 25, 2011 by Lukas Pokorny (124,610 points)
I just sent you a link to the current build. Please give it a try and let us know whether it solves the problem.
...