0 votes
by (200 points)


Our customer getting strange error for one server where they do have read/write permission. Looks like following piece of code failing when GetItems is called. client is FileTransfer Client. Customer tried other Free Clients like WinSCP and tools from other vendor and it worked fine. Any clue would be highly appreciated.

var list = client.GetItems(fs); 

More info from exception

ProblemType : NotFileOrDirectory
RemotePath : /Myfile.txt
Status : UnclassifiableError
SftpStatus : UnclassifiableError

HResult : -2146233088 (0x80131500)

Platform: Win32NT 6.1.7601.65536
CLRVersion : 4.0.30319.42000

Applies to: Rebex SFTP

1 Answer

0 votes
by (70.5k points)

The exception says that the FileTransferClient was unable to determine the type of the item - file or directory ("/Myfile.txt" in your case).

Can you please post here or send to support@rebex.net DEBUG communication log? It can be created like this:

var client = new FileTransferClient();
client.LogWriter = new Rebex.FileLogWriter("log_path", Rebex.LogLevel.Debug);