SFTP Connection Error

0 votes
asked Feb 23, 2016 by vertisoft (160 points)

I am using a trial version of Rebex SFTP server and running it as a service on Windows Server 2012. I am binding the SFTP protocol to port 5877. When I attempt to connect using WinSCP, I get: Network error: connection timed out. I thought it might be a firewall issue, so I changed the binding to an internal IP address (192.168.168.210) that is not behind the firewall to confirm and I still get the same error. Here is the log file communication information:

2016-02-23 10:17:51.767 Opening log file.
2016-02-23 10:17:51.767 Using FileLogWriter version 2.0.5855.0.
2016-02-23 10:17:51.908 INFO FileServer(1)[4] Server: Starting server.
2016-02-23 10:17:51.924 INFO FileServer(1)[4] Server: Listening for connections at 0.0.0.0:5877.
2016-02-23 10:17:51.924 INFO FileServer(1)[4] Server: Listening for connections at 192.168.168.210:5877.
2016-02-23 10:17:51.924 INFO FileServer(1)[4] Server: Server started.

Thanks for any help to resolve this issue.

1 Answer

+1 vote
answered Feb 25, 2016 by Tomas Knopp (58,890 points)
selected Feb 25, 2016 by vertisoft
 
Best answer

Hello,

to make sure that the TCP port 5877 is opened, I created a very simple client and server that only uses .NET TcpClient and no Rebex components. At first, please try to test whether you are able to establish the connection from the client to your server with these two minimalistic programs and let me know how it went.

I believe you will have to setup the Windows Firewal correctly at the server machine. At least enable the port for the application to be able to accept incoming connections at your chosen port.

Here is a link to the simple TCP client and server.
Please give it a try and let me know how it went. A good way to start is trying to connect to the server locally (client app being installed on the server itself.) if it succeeds, try to move the client to another computer on your LAN, eventually on bigger networks.

commented Feb 25, 2016 by vertisoft (160 points)
Thanks for your help Tomas. As you suggested, it was the Windows firewall that was blocking the port! Opening port 5877 on the Windows 2012 server firewall solved the problem.
commented Feb 26, 2016 by Tomas Knopp (58,890 points)
Good to hear that it works now :-) thanks for your comment.
...