Support for Extended Passive Mode EPSV?

0 votes
asked May 6, 2014 by PeteF (160 points)
edited Jul 18, 2014

I'm trying to connect to an FTPS server that requires use of Extended Passive Mode (EPSV). When starting the file transfer the FTP object is sending the standard PASV command which results in the following error.

[Rebex.Net.FtpException] No connection could be made because the target machine actively refused it.

Is EPSV supported by the Rebex FTP libraries and if so how is it configured when using FTPS?

There doesn't appear to be anything relating to this in the documentation, FTP object model or release notes.

For reference I am currently using an older version of the File Transfer Pack, version 1.0.4086.

Applies to: Rebex FTP/SSL

1 Answer

+1 vote
answered May 6, 2014 by Lukas Pokorny (120,490 points)
edited Jul 18, 2014
 
Best answer

Rebex FTP/SSL only uses Extended Passive Mode (EPSV) when connected to an FTP server using IPv6. It can't be currently configured to use EPSV for IPv4 as well. Do you simply need an option to force EPSV instead of PASV? That would be easy to add.

commented May 8, 2014 by PeteF (160 points)
edited May 8, 2014

Unfortunately IPv6 isn't an option for us in this instance. If it's possible to also enable it on IPv4 that would be great. What's the general release strategy for things like this?

commented May 8, 2014 by Tomas Knopp (58,890 points)
edited May 8, 2014

Hello, do I understand correctly that adding the option which would force EPSV instead of PASV would fit your needs? If yes, we would be able to issue a hotfix in the beginning of next week which will include the option and send you a link to download.

commented May 8, 2014 by Lukas Pokorny (120,490 points)
edited May 8, 2014

OK, we will add an option to enable it on IPv4. This will become part of the next release. Until then, we can provide a custom hotfix (based on the latest release) - it should be ready early next week.

commented May 12, 2014 by Lukas Pokorny (120,490 points)
edited Jul 10, 2014

We added ForceExtendedDataChannelCommand options for the next release. It can be enabled by setting Ftp.Settings.ForceExtendedDataChannelCommand to true.

commented Jul 10, 2014 by Lukas Pokorny (120,490 points)
edited Jul 10, 2014

This has been released with Rebex FTP/SSL 2014 R2.

commented Jul 18, 2014 by PeteF (160 points)
edited Jul 18, 2014

Thanks for adding this option. We've now upgraded to 2014 R2 and it's working a treat.

...