Telnet TerminalName / iSeries WorkstationID

0 votes
asked Mar 21, 2013 by tomkennedy (190 points)
edited Apr 2, 2013

Hi,

I'm trying to create a TelnetTerminal session to our IBM iSeries. I've got the connection working (which was very easy, kudos to rebex!) but now I need to configure how it connects.

For example, connecting through our usual emulators we specify a 'WorkstationID' which will configure how the screen appears based on the name (eg. if the WorkstationID has 'scan' in it, the screen will be configured for viewing on a scanner).

I thought the property TerminalName for the TelnetTerminalControl would do it, but it doesn't seem to be working.

Does anybody have any advice?

Thanks, Tom

commented Mar 21, 2013 by Lukas Matyska (60,650 points)
edited Mar 21, 2013

Have you set the TelnetTerminalControl.Options.TerminalName before you call Connect method? It is necessary, because terminal name is reported to the remote end shortly after the connection is established and only if the remote end asks for it.

commented Mar 26, 2013 by tomkennedy (190 points)
edited Mar 27, 2013

Hi, thanks for the reply.

Yup, I'm setting the properties before calling Connect():

TelnetTerminalControl1.ServerName = "ourservername"
TelnetTerminalControl1.Options.TerminalName = "scan"
TelnetTerminalControl1.Connect()

Perhaps it's something at our server end that's the problem, though having said that all the clients I've tested with all behave correctly when I've set the name..hmmm...

commented Mar 27, 2013 by Lukas Matyska (60,650 points)
edited Mar 27, 2013

Can you please create a communication log of the TelnetTerminalControl and also of your usual emulator and send it to support@rebex.net for comparison? Maybe we can spot some important difference.

Communication log of the Rebex control can be done like this:

TelnetTerminalControl1.LogWriter = new Rebex.FileLogWriter("C:\temp\telnet.log", Rebex.LogLevel.Verbose)
commented Apr 2, 2013 by tomkennedy (190 points)
edited Apr 2, 2013

Hi, As it turns out we are using the telnet session in a different way now, so I have no need to set the terminal name.

Thanks for your help anyway. Tom

1 Answer

0 votes
answered Apr 3, 2013 by Lukas Pokorny (124,970 points)

In case anyone else runs into the same issue - please try creating two Wireshark logs:

  • One log showing a Rebex Telnet connection with the terminal name set.
  • Another log showing a connection from one of your usual emulators that works as excpected.

By comparing the two logs, we should be able to determine what went wrong and how to solve it.

...