0 votes
by (120 points)

Rebex is not retrieving image files with %20 (space) in the name. Example:

09:14:18.453 Request(242): GET /img/MM/Warhorse.png (client: [::1]:52049)
09:14:18.464 Request(242): Sending response: 200 OK (file: /img/MM/Warhorse.png; type: image/png)
09:14:24.583 Request(243): GET /img/MM/Warhorse%20Skeleton.png (client: [::1]:52055)
09:14:24.590 Request(243): Sending response: 404 Not Found (file: C:\Apps\Rebex\wwwroot\img\MM\Warhorse%20Skeleton.png)

Both of these files are verified as existing.

Installed Microsoft Windows IIS (default optional feature) on Windows 10 and the response happens as expected - each file is retrieved for each respective call.

1 Answer

0 votes
by (70.4k points)

This is known limitation of version 1.0.0. However, we already implemented URI decoding to fix that. Please download the latest version now.

From version 1.0.1 URI decoding is enabled by default. You can still disable it in the .config file like this:

<add key="decodeUri" value="false" />
...