0 votes
by (1.7k points)

Hello.
If "WWW-Authenticate" is Digest in Rebex Https (R5.5), PreAuthentication does not work.
If it is "Basic", it works fine.
In my case, PreAuthentication does not work, and the problem becomes serious when I upload a file with PUT.

Please let me know how I can temporarily fix this issue right now.
For example, please tell me how to temporarily force the Digest Authentication Header.

Applies to: Rebex HTTPS
by (1.7k points)
Server 401 Response
WWW-Authenticate: Digest realm="HERE2", nonce="9e8050014bfa8d34b7ce2cb0d0890e46", qop="auth"\r\n

If I manually put Authentication Header for digest for every request, it works properly.
However, since this is a very simple code, I want PreAuthenticate to work properly.
by (134k points)
Hello, to be able to help, we need more information than "does not work". Would it be possible to create a log at LogLevel.Debug (https://www.rebex.net/kb/logging/) and mail it to us for analysis?
by (1.7k points)
I will send the log file to the Support mail.
by (134k points)
Thanks, we'll look into this!
by (62.8k points)
Hello, I have sent you link to beta version with PreAuthentication enabled for Digest authentication to your email.

1 Answer

+1 vote
by (62.8k points)
selected by
 
Best answer

The PreAuthentication was supported for Basic authentication only.

We added support for Digest authentication as well. It will be included in the next release.

by (1.7k points)
The last beta version works perfectly.
Thank you very much for your quick response.
by (134k points)
This has been included in Rebex HTTPS R5.6: https://www.rebex.net/https/history.aspx#R5.6
...