450 error connecting to FTP requiring explicit FTP over TLS

+1 vote
asked Sep 21, 2015 by jenn2157 (190 points)
edited Sep 22, 2015 by Tomas Knopp

Hello,

I am receiving the following error:

"TLS session of data connection has not resumed or the session does not match the control connection (450)."

I know this is related to TLS session resumption because when I ask the administrator to disable this setting, I am able to connect. My question is, how can I connect with it enabled?

Are my binaries outdated?

Applies to: Rebex FTP/SSL

1 Answer

+1 vote
answered Sep 22, 2015 by Tomas Knopp (58,890 points)
selected Sep 22, 2015 by jenn2157
 
Best answer

You need to enable reusing of the control session. This option is enabled by default since Rebex FTP/SSL release 2015R4.

Older versions of Rebex FTP/SSL client actually do support SSL session reusing (and it's enabled by default), but they only reuse data sessions, not the control session. Fortunately, reusing the control session can be enabled even under the old versions using the ReuseControlConnectionSession option like this:

var ftp = new Ftp();
...
ftp.Settings.ReuseControlConnectionSession = true;

Please give this a try and let me know whether it helps.

commented Sep 22, 2015 by jenn2157 (190 points)
Thanks!  Setting this option worked.  I do have an old version and am using VB.NET so the line I included just before the connect is:

ftp.Options = FtpOptions.ReuseControlConnectionSession

Thanks again!
commented Sep 22, 2015 by Tomas Knopp (58,890 points)
Thank for letting us know! BTW enabling the option in older version should be done like this:

C#

    ftp.Options |= FtpOptions.ReuseControlConnectionSession;

VB

    ftp.Options = ftp.Options Or FtpOptions.ReuseControlConnectionSession

This way you will not override existing FtpOptions if some were already set in your program.
commented Sep 22, 2015 by jenn2157 (190 points)
Got it.  Thanks!
...