Unable to resolve hostname on WinCE

0 votes
asked Jun 12 by Lukas Matyska (44,590 points)

(Note: this was originally asked at comment)

Hi Lukas,

We are working on this. we got an another clarification also on - using Hostname for https mode

  • the

2018-06-11 20:10:07 DEBUG HttpRequest(1)[112918690] HTTP: Using new HTTP session (1).
2018-06-11 20:10:07 INFO HttpRequest(1)[112918690] HTTP: Connecting to 'https://ttopweb1qa:443'...
2018-06-11 20:10:07 DEBUG HttpRequest(1)[112918690] Info: Assembly: Rebex.Common 2018 R1.1 for .NET Compact Framework 3.5
2018-06-11 20:10:07 DEBUG HttpRequest(1)[112918690] Info: Platform: Windows CE 6.0.0 32-bit; CLR: 3.5.10010.0
2018-06-11 20:10:07 DEBUG HttpRequest(1)[112918690] Info: Culture: en; windows-1252
2018-06-11 20:10:07 DEBUG HttpRequest(1)[112918690] Proxy: Resolving 'ttopweb1qa'.
  • with the above Line - My application getting exception on Crash.
  • Please let me know - whether the host name is resolved in Rebex level?
  • I have entrolled the host name detail WINCE device as per below suggestion

https://support.microsoft.com/en-us/help/199370/how-to-load-host-entries-into-windows-ce-device

1 Answer

0 votes
answered Jun 12 by Lukas Matyska (44,590 points)

The host name is resolved by Rebex component using system Dns.GetHostEntry() method. If this fail, we cannot do much. You have to setup your device correctly first.

Actually, the log you provided doesn't contain the exception. Can you please post here the exception as well?

Also, you are connecting to "https://ttopweb1qa". This does not look like correct host name. Are you missing Top-level domain?

For example: "https://ttopweb1qa.com"

commented Jun 13 by RajaK (110 points)
hi Luka,
 After setting the hostname to IP mapping in device  - we able to resolve the  host name

 - but we facing the issue with the Certificate Validation  - its throwing below error

018-06-13 16:34:13 DEBUG HttpRequest(1)[69140706] TLS: HandshakeMessage:ServerHelloDone was received.
2018-06-13 16:34:13 DEBUG HttpRequest(1)[69140706] TLS: Verifying server certificate ('O="testserver.", C=US, OU=MULTI-ALLOWED, OU=SIMPLE-SSL, CN=TTOPWEB1QA').
2018-06-13 16:34:14 INFO HttpRequest(1)[69140706] TLS: Certificate verification status: IncompleteChain (65536)
2018-06-13 16:34:14 DEBUG HttpRequest(1)[69140706] TLS: Certificate verification result: UnknownAuthority
2018-06-13 16:34:14 DEBUG HttpRequest(1)[69140706] TLS: Error while processing TLS packet: Rebex.Net.TlsException: Server certificate was rejected by the verifier because of an unknown certificate authority.

 - when we done the initial testing we were able to success - but with other server

018-01-08 19:16:06 DEBUG HttpRequest(1)[110690990] TLS: HandshakeMessage:ServerHello was received.
2018-01-08 19:16:06 INFO HttpRequest(1)[110690990] TLS: Using TLS 1.2.
2018-01-08 19:16:06 DEBUG HttpRequest(1)[110690990] TLS: The server supports secure renegotiation.
2018-01-08 19:16:06 DEBUG HttpRequest(1)[110690990] TLS: HandshakeMessage:Certificate was received.
2018-01-08 19:16:06 DEBUG HttpRequest(1)[110690990] TLS: HandshakeMessage:ServerHelloDone was received.
2018-01-08 19:16:06 DEBUG HttpRequest(1)[110690990] TLS: Verifying server certificate ('O="test1server.", C=US, OU=MULTI-ALLOWED, OU=SIMPLE-SSL, CN=IP).
2018-01-08 19:16:06 DEBUG HttpRequest(1)[110690990] TLS: Certificate verification result: Accept
2018-01-08 19:16:06 VERBOSE HttpRequest(1)[110690990] TLS: Sent TLS packet:


 - is there any way to handle this?
commented Jun 14 by Lukas Matyska (44,590 points)
The `Certificate verification status: IncompleteChain` and `Certificate verification result: UnknownAuthority` means that you have not installed Root certificate of the server in your device.

The correct solution is to install Root certificate for `CN=TTOPWEB1QA` to your device. Other solutions are discussed at http://blog.rebex.net/howto-server-certificate-rejected-exception/

In case of WCF, the appropriate settings are accessible by WcfBinding.RequestCreator.Settings property.
...