Rebex Secure Mail POP3 Connect from Windows Service is extremly slow

0 votes
asked Sep 18, 2013 by pop3user (210 points)
edited Sep 20, 2013

Hi,

We use the following c# code:

Pop3 pop = new Pop3();
pop.Settings.SslAcceptAllCertificates = true;
pop.Connect(serverName, 110, SslMode.None);
pop.Login(userName, password);

The Connect method takes half second if it is called from Windows Forms Application, but it takes 30 seconds if it was called from Windows Service. Tried several times.

Why is it? How can I or you fix this?

OS: Windows 7 Professional 64 bit

Rebex Components 2013 R2 v2.0.4981.0 (.NET 2.0)

Window Service uses .NET 3.5

When using other pop3 server with Implicit SSLmode and different port, it works well and fast.

Thanks

Applies to: Rebex Secure Mail

2 Answers

+1 vote
answered Sep 20, 2013 by pop3user (210 points)
edited Sep 20, 2013
 
Best answer

Finally I found the solution. The anti-virus software caused the 30 seconds delay, likely it analyzes the port 110 traffic.

0 votes
answered Sep 19, 2013 by Tomas Knopp (58,890 points)
edited Sep 20, 2013

Hello,

could you please run the same code which causes problems from: A) Windows Service application B) Windows Forms application

In both variants, please create a log as described at http://www.rebex.net/kb/logging/default.aspx

And send both logs back to support@rebex.net, or post it here. We’ll be able to look into your issue then.

commented Sep 20, 2013 by pop3user (210 points)
edited Sep 20, 2013

The problem occurred only on one computer and it is reproducable without using Rebex components, with using .NET tcp classes alone.

...